bug on SMTP Account SMTP IP Pool for MTA

mhourani

Beginner
Dec 27, 2020
8
0
1
Hello,
there is an a bug on SMTP IP Pool for MTA.
the issue is the maximum IP can be assign is 20 IP address.
 

wasif

Administrator
Staff member
Apr 9, 2019
460
85
28
Which edition of Mumara you are referring to? And share any snapshot or the error you see!
 

mhourani

Beginner
Dec 27, 2020
8
0
1
Hello,
i'm talking about ESP Edition , no error shown when we add all ip , and click on submit the message shown your data save , but when we refresh the page the the saved only 20 IP Address
 

wasif

Administrator
Staff member
Apr 9, 2019
460
85
28
Look into my private message, I just sent.
 

wasif

Administrator
Staff member
Apr 9, 2019
460
85
28
It could be PHP configuration issue. Edit your server's php.ini file and increase the value for max_input_vars. For the case, try setting some higher value e.g. 100000, and restart apache. Check if it works!
 

mhourani

Beginner
Dec 27, 2020
8
0
1
It could be PHP configuration issue. Edit your server's php.ini file and increase the value for max_input_vars. For the case, try setting some higher value e.g. 100000, and restart apache. Check if it works!
Not working , same issue
 

wasif

Administrator
Staff member
Apr 9, 2019
460
85
28
You are trying to assign IPs to the user accounts if I am right? And when you select more than 20 Ips, it just assigns 20? If yes, then check if the IPs are in the available state, and not reserved or dedicated. However, it shouldn't show reserved IPs but still, check if they are in the available state. Any snapshots will be appreacted. You can blur your snapshots.
 

mhourani

Beginner
Dec 27, 2020
8
0
1
Hello, after tracking this case the issue from database , check the attached file
 

Attachments

  • 01111.png
    01111.png
    23.9 KB · Views: 4

mhourani

Beginner
Dec 27, 2020
8
0
1
kindly note after change the column size from 300 to 1000 it's saved , so this is the issue you should update size of column
 

wasif

Administrator
Staff member
Apr 9, 2019
460
85
28
Ahh, yes that can be an issue. You can simply change the type of the field smtp_pool to TEXT. And then try again, it should work. Do let me know if it fixes the issue.
 

wasif

Administrator
Staff member
Apr 9, 2019
460
85
28
Yes, I noticed the same. Better if you change to the TEXT field instead of doing VARCHAR(1000). This way it will eat more database space.