Updating from PHP7.x to PHP8.1 (v5.5)

wasif

Administrator
Staff member
Apr 9, 2019
568
110
43
Mumara Version v6.0 can run on PHP8.1 and higher versions. The core framework and modules have been updated. If you are using PHP7.4, it will be supported until v5.4.7. After that, you must upgrade your PHP to 8.1 before upgrading Mumara to v6.0.

If you use a control panel like cPanel or Plesk, upgrading your PHP from the GUI should be simple. However, if you do not have a control panel, it may be challenging, especially if you are not tech-savvy. In such cases, it is recommended to contact your Server Administrator to help with the upgrade.

While shifting to PHP8.1, ensure you have installed all required PHP extensions and the Ioncube loader.

If you used the command-line installer to set up your server, the following command could upgrade you to PHP8.1 and Ioncube 12.

Code:
cd /home && curl -o mumara_php_converter.sh -L https://dl.mumara.com/campaigns/tools/mumara_php_converter.sh && sh mumara_php_converter.sh

To update Mumara, follow these steps:
  1. Update your Mumara to v5.4.7. As you are using PHP7.x, the update process will automatically update you to v5.4.7.
  2. Upgrade your PHP to 8.1.
  3. Put `/update` after your Mumara URL (e.g., mumaraurl.com/update) to launch the update wizard.
  4. Follow the wizard's steps to complete the update.
If you encounter any difficulties, please submit a support ticket under your account.
 
Last edited:

dimivee

Beginner
Mar 31, 2023
6
0
1
I had problems with PHP 8.2 and Ioncube. Basically it said that the Mumara code was not compatible with the Ioncube loader for PHP 8.2. I went back to PHP 7.4.
 

wasif

Administrator
Staff member
Apr 9, 2019
568
110
43
What version were you updated to? As we haven't launched the 8.1 updates yet!
 

dimivee

Beginner
Mar 31, 2023
6
0
1

wasif

Administrator
Staff member
Apr 9, 2019
568
110
43
Yes, the current version is supported on PHP7.4, but the new version/updates that we are about to launch in a day or two should be supported on PHP8.1 and higher.